Blank QuickLaunch Icons on View Desktop

I’ve been doing a several VMware View installs for customers this month.  During one of the engagements I ran into a strange issue where the Quick Launch icons on the Windows Taskbar of provisioned Linked Clones were blank.  Here’s what it looked like:

Windows QuickLaunch Icons Blank White

Clicking on the icons resulted in a warning: “Can’t open this item.  It might have been moved, renamed, or deleted.  Do you want to remove this item?”  No, Windows; I don’t want you to remove it, I just want you to fix it, thank you very much.

QuickLaunch Cant Open This Item

I did a bit of digging and found another user on the VMware Communities forum had the same issue but no resolution.  A little more looking pointed me at this post by Chris Kliewer.  Chris identified the problem and provides a solution.  Here’s what’s going on:

I used Sysprep to copy the user profile that I customized / optimized by specifying the CopyProfile paramater.  When the customized profile is copied to the Default profile a couple folders go missing .  To fix the problem edit your template after Syspreping by adding the following folders – “User Pinned” and “Taskbar” as follows:

  •  C:UsersDefaultAppDataRoamingMicrosoftInternet ExplorerQuick LaunchUser Pinned
  • C:UsersDefaultAppDataRoamingMicrosoftInternet ExplorerQuick LaunchUser PinnedTaskbar

Shut down.  Snapshot.  Recompose.  Done.

It looks like this problem can affect local profiles, as well as profiles managed by View Persona Managment and Liquidware Labs ProfileUnity.

If you want to automate or customize the pinned icons in the Quick Launch taskbar, see the script provided here: http://theitbros.com/copy-taskbar-icons-windows-7-sysprep-v2/.

Drop a comment below:

%d bloggers like this: